summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMinze Zwerver2018-08-24 22:24:06 +0200
committerMinze Zwerver2018-08-24 22:24:06 +0200
commit2b3a1e209bfa92a01f98a09019e261c81142a82f (patch)
tree6c9c34d6f5b1ea13bb02214b7528daf113144092 /PKGBUILD
parenta19bd5bc70ee4ebc0ee9e6f4bd3e106da2c0b8e0 (diff)
downloadaur-starruler2-git.tar.gz
changed the PKGBUILD to be more "clean"
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3dad4957c3f2..62bf6936bd93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
# Maintainer: Ysblokje <ysblokje at gmail dot com>
# git version for the opensourced starruler2
pkgname=starruler2-git
-pkgver=dad50e1
+pkgver=r27.ba99a9a
pkgrel=1
pkgdesc="4X Space Strategy game Star Ruler 2's open source distribution."
arch=('x86_64')
url="http://starruler2.com/"
license=('MIT')
depends=('libpng' 'zlib' 'glew' 'glu' 'freetype2' 'libvorbis' 'libogg' 'openal' 'bzip2' 'libxrandr' 'curl')
-optdepends=()
makedepends=('git' 'cmake' 'imagemagick' 'gcc' 'make')
provides=('starruler2')
-conflicts=()
-source=("git+https://github.com/BlindMindStudios/StarRuler2-Source.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/BlindMindStudios/StarRuler2-Source.git"
+ "starruler2.desktop")
+sha256sums=('SKIP'
+ 'c2df769b599b5f9ba5804052f8a32c2625fd99be9201660830f2be405f374e0b')
pkgver() {
cd StarRuler2-Source
- echo $(git rev-parse --short HEAD)
+# echo $(git rev-parse --short HEAD)
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
@@ -34,11 +35,11 @@ package() {
echo "package"
dest=${pkgdir}/opt/starruler2/
mkdir -p ${pkgdir}/usr/share/{pixmaps,applications}
- cp ${startdir}/starruler2.desktop ${pkgdir}/usr/share/applications/
+ cp -dpr --no-preserve=ownership starruler2.desktop ${pkgdir}/usr/share/applications/
cd ${srcdir}/StarRuler2-Source
- cp sr2.png ${pkgdir}/usr/share/pixmaps/
+ cp -dpr --no-preserve=ownership sr2.png ${pkgdir}/usr/share/pixmaps/
mkdir -p ${dest}
chmod +x StarRuler2.sh
- cp -a StarRuler2.sh ${dest}
- cp -a bin maps mods locales data scripts ${dest}
+ cp -dpr --no-preserve=ownership StarRuler2.sh ${dest}
+ cp -dpr --no-preserve=ownership bin maps mods locales data scripts ${dest}
}