summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthias Piepkorn2018-10-28 21:28:21 +0100
committerMatthias Piepkorn2018-10-28 21:30:13 +0100
commit388ffb1bdc6ca024ed68a42a2f0cdafb2dead0f9 (patch)
tree74e8c5656847dc3f09330cfe7c2994ee35d15491 /PKGBUILD
downloadaur-388ffb1bdc6ca024ed68a42a2f0cdafb2dead0f9.tar.gz
create initial package for stash-electron 1.1.1pre-30
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb692980d2ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: chendaniely <chendaniely@gmail.com>
+# Contributor: Conor Anderson <conor@conr.ca>
+
+pkgname=stash-electron-git
+_pkgname=${pkgname%-git}
+_appname=Stash
+pkgver=1.1.1pre
+pkgrel=30
+pkgdesc="Stash Team Secret Manager"
+url='https://github.com/Doccrazy/stash-electron'
+arch=('x86_64')
+license=('GPL-3.0')
+depends=('alsa-lib' 'gconf' 'gtk3' 'libxss' 'libxtst' 'nss' 'libsecret' 'libcurl-gnutls')
+conflicts=('stash-electron')
+
+source=("${pkgname}_${pkgver}-${pkgrel}_amd64.deb::https://bintray.com/doccrazy/deb/download_file?file_path=${pkgname}_${pkgver}-${pkgrel}_amd64.deb"
+ "LICENSE")
+sha256sums=('9375a5a15aa1866ae96bea4a2d63973fd9b0b5ed03e264b0e798473e25fd4691'
+ '8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903')
+
+package() {
+ cd "$srcdir"
+ ar xf "${pkgname}_${pkgver}-${pkgrel}_amd64.deb"
+ tar xf data.tar.xz
+
+ # Place files
+ install -d "${pkgdir}/usr/lib/${_pkgname}"
+ cp -a "${srcdir}/opt/${_appname}/"* "${pkgdir}/usr/lib/${_pkgname}"
+
+ # Symlink main binary
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/usr/lib/${_pkgname}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+
+ # Place desktop entry and icons
+ sed -i "s/opt\/${_appname}/usr\/lib\/${_pkgname}/" "${srcdir}/usr/share/applications/${_pkgname}.desktop"
+ desktop-file-install -m 644 --dir "${pkgdir}/usr/share/applications/" "${srcdir}/usr/share/applications/${_pkgname}.desktop"
+ install -dm755 "${pkgdir}/usr/share/icons/hicolor/"
+ cp -R "${srcdir}/usr/share/icons/hicolor/"* "${pkgdir}/usr/share/icons/hicolor/"
+
+ # Place license files
+ for license in "LICENSE.electron.txt" "LICENSES.chromium.html"; do
+ install -Dm644 "${pkgdir}/usr/lib/${_pkgname}/${license}" "${pkgdir}/usr/share/licenses/${_pkgname}/${license}"
+ rm "${pkgdir}/usr/lib/${_pkgname}/${license}"
+ done
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}