summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgustawho2022-07-01 23:10:12 -0600
committergustawho2022-07-01 23:10:12 -0600
commita15090a0315f8189fcd767b468c2ea58f9d859c3 (patch)
treed83638e403a0a244c7f7310055763341acf9e614 /PKGBUILD
parent69bd4dcd3b1fd1e6e1acf8686a9732d0ec7fb490 (diff)
downloadaur-station-git.tar.gz
PKGBUILD format
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4f0c8029953f..0da868b722c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
-# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
+# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
pkgname=station-git
-pkgver=v1.1.1.r7.gfc3a700
-pkgrel=2
+pkgver=2.1.2.r4.gfe4f056
+pkgrel=1
pkgdesc="Convergent terminal emulator"
arch=('x86_64')
groups=('maui-apps')
url="https://invent.kde.org/maui/station"
license=('GPL3')
-depends=('kio' 'mauikit-git' 'ki18n')
+depends=('kio' 'mauikit-git' 'ki18n' 'qmltermwidget')
makedepends=('git' 'extra-cmake-modules')
provides=('station')
conflicts=('station')
@@ -18,8 +18,8 @@ sha256sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags --first-parent --match 'v[0-9][0-9.][0-9.]*' | \
+ sed 's=^v==;s=^\([0-9][0-9.]*\)-\([a-zA-Z]\+\)=\1\2=;s=\([0-9]\+-g\)=r\1=;s=-=.=g'
)
}