summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChenx Dust2024-05-06 00:41:03 +0800
committerChenx Dust2024-05-06 00:41:03 +0800
commit2d919e0931095ad4bf2d8b80c603bf749c4f2796 (patch)
treea3459ed3e620c847214995513576f31b36717fc6 /PKGBUILD
downloadaur-2d919e0931095ad4bf2d8b80c603bf749c4f2796.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48437218b26a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Chenx Dust <chenx_dust@outlook.com>
+
+pkgname=steam-gamepadui-session-git
+_gitown=chenx-dust
+_gitdir=steam-gamepadui-session
+pkgver=0.1
+pkgrel=1
+pkgdesc="Steam Big Picture session based on gamescope for vanilla Arch Linux"
+arch=('any')
+url="https://github.com/${_gitown}/${_gitdir}"
+license=('MIT')
+groups=()
+depends=('steam' 'gamescope' 'gamescope-session-git')
+optdepends=(
+ 'ttf-dejavu: for initial screen text'
+ 'steam_notif_daemon: notify daemon'
+ 'ibus: input support'
+ 'steam-removable-media-git: removable media support'
+ 'gamemode: for performance tuning'
+ 'lib32-gamemode: for performance tuning'
+)
+conflict=('gamescope-session-steam-git')
+makedepends=('git')
+source=("${_gitdir}::git+https://github.com/${_gitown}/${_gitdir}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_gitdir}"
+
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${_gitdir}"
+ cp -rv "${srcdir}/${_gitdir}/usr" "${pkgdir}/usr"
+ install -Dm644 "${srcdir}/${_gitdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # font workaround for initial big picture mode startup
+ mkdir -p "${pkgdir}/usr/share/fonts/truetype/ttf-dejavu"
+ ln -s "/usr/share/fonts/TTF/DejaVuSans.ttf" "${pkgdir}/usr/share/fonts/truetype/ttf-dejavu/DejaVuSans.ttf"
+}
+