summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShyPixie2023-04-27 20:38:41 -0300
committerShyPixie2023-08-05 06:51:28 -0300
commit9ebad45941c7a58959df2e62ad26f1972ace8754 (patch)
tree23699fa60fafd809abaac5b057739abbce3e6363 /PKGBUILD
parenta39f509a0e38f57d66b8fd8d012ed0b36aef0c64 (diff)
downloadaur-9ebad45941c7a58959df2e62ad26f1972ace8754.tar.gz
Readd pygobject fix to steam-tools-ng
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5473c968c530..36e814177791 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=steam-tools-ng
pkgver=3.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Some useful tools for use with steam client or compatible programs, websites"
arch=('any')
url="https://github.com/calendulish/steam-tools-ng"
@@ -13,8 +13,15 @@ makedepends=('python-build' 'python-installer' 'python-wheel' 'imagemagick')
license=('GPL')
source=(
"https://github.com/calendulish/$pkgname/archive/v${pkgver}.tar.gz"
+ "https://github.com/calendulish/$pkgname/commit/b49deac04211c6c010a6db0f3b9cc06a646fd0c1.patch"
)
-sha256sums=('4af918fd74c020451eef29375781c6bb2cb7a05afba4e64f05a886b3fe84ca89')
+sha256sums=('4af918fd74c020451eef29375781c6bb2cb7a05afba4e64f05a886b3fe84ca89'
+ '6433d67ca6a0a4555cbff98314ff5c196f32ca8dcf6519cf86a093269da322cc')
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -Np1 < "../b49deac04211c6c010a6db0f3b9cc06a646fd0c1.patch"
+}
build() {
cd $pkgname-$pkgver