summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxomachine2018-04-09 20:12:38 +0300
committerxomachine2018-04-09 20:12:38 +0300
commit6c1a36e7646c56a66e12b595fa7ebb180c2d4565 (patch)
tree1ef49cb1310d78b82314738be9c7789f28fda1b5 /PKGBUILD
parent811dc6290c3b38aa0c42a33c52bc64d52fc13087 (diff)
downloadaur-6c1a36e7646c56a66e12b595fa7ebb180c2d4565.tar.gz
Updated build according to latest changes
Removed tests target in make. Now all library wrappers are being compiled by default. Allowed multijob builds since it properly handled in Makefile.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d9c7b393d477..1767f17efce5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=('steamforwarder-git')
_pkgname=SteamForwarder
pkgdesc="Tool that allows interaction between windows games under wine and the linux steam. (Cutting edge experimental features)"
-pkgver=r157.789cb0a
+pkgver=r182.8740de2
pkgrel=1
arch=('x86_64' 'i686')
url="https://github.com/xomachine/SteamForwarder"
@@ -26,17 +26,13 @@ pkgver() {
build() {
cd "$srcdir/${_pkgname}"
- make -j1 tools
+ make tools
# Touch required to avoid signatures.txt rebuilding when make install
touch signatures.txt
+ make precompile
}
package() {
cd "$srcdir/${_pkgname}"
make install PREFIX="/usr" DESTDIR="${pkgdir}"
}
-
-check() {
- cd "$srcdir/${_pkgname}"
- make tests
-}