summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfrostworx2020-09-25 08:34:17 +0200
committerfrostworx2020-09-25 08:34:17 +0200
commit4e49cbf0d651f80b94d0a6d2e44b31399515232f (patch)
tree682069fd7a14882e6d5a351ab5d0bd981480cf1c /PKGBUILD
parent6fa7d27a2fe3f85acf055f432db1d716d55da61c (diff)
downloadaur-4e49cbf0d651f80b94d0a6d2e44b31399515232f.tar.gz
update to v2.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 549c628615d3..b4ee57400b14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,16 @@
# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Co-Maintainer: Marcel Unbehaun <f.rostze.ux at gmail dot com>
pkgname=steamtinkerlaunch
-pkgver=1.6.6
+pkgver=2.0.0
pkgrel=1
pkgdesc="Wrapper script for Steam custom launch options"
arch=('any')
url="https://github.com/frostworx/steamtinkerlaunch"
license=('GPL3')
-depends=('bash')
+depends=(
+ 'bash'
+ 'yad'
+)
optdepends=(
'strace: write a strace log of the launched game'
'gamemode: for using GameMode per game'
@@ -30,17 +33,18 @@ optdepends=(
'wine: for optional Vortex Mod Manager support'
'gameconqueror: for optional cheating'
'xorg-xprop: for optional window toggle and side-by-side VR'
+ 'gamescope: for optional GameScope support'
)
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('7dd1678159c23568223cf2a35c393a3c5d98cb3a0887c740e52c65ec46d4bfe4')
+sha256sums=('e618a63b68d1a354d65a765b3eefbabb3127abb7cd97822a18a079da06a9d02d')
package() {
cd "$srcdir/$pkgname-${pkgver}"
install -Dm755 stl -t "$pkgdir/usr/bin"
install -d "$pkgdir/usr/share/stl"
- cp -r categories regs tweaks "$pkgdir/usr/share/stl"
+ cp -r categories misc regs tweaks "$pkgdir/usr/share/stl"
install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
}