summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlan Jenkins2020-07-08 17:59:06 +0100
committerAlan Jenkins2020-07-08 18:03:30 +0100
commit5e5bd56725fc1a22130c2e8862006439aa540454 (patch)
treecc14b429a54ee854341227762b9c859d52e55652 /PKGBUILD
parent04192d4bf9a770d4bfd1d5107e859dd91b5ae875 (diff)
downloadaur-5e5bd56725fc1a22130c2e8862006439aa540454.tar.gz
Update to 0.94
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fabb4185d026..616a7823c2b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# https://aur.archlinux.org/packages/steamtinkerlaunch
pkgname=steamtinkerlaunch
-pkgver=0.921
+pkgver=0.94
pkgrel=1
pkgdesc="Wrapper script for Steam custom launch options"
arch=('any')
@@ -26,19 +26,21 @@ optdepends=(
'vr-video-player: for playing regular games side-by-side in VR'
'xdg-utils: for opening the ProtonDB URL of started game'
)
-_commit='25587777ce92159260595dfe5fef0080bf9c8569'
+_commit='d5a1788f21ec9165bd1cf73b2d78213f5ab43d01'
source=("git+https://github.com/frostworx/steamtinkerlaunch.git#commit=$_commit")
sha1sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
- printf $(grep 'PROGVERS=' stl | head -n1 | cut -d\" -f2 | sed 's/^v//')
+ cd "$srcdir/$pkgname"
+ printf $(grep 'PROGVERS=' stl | head -n1 | cut -d\" -f2 | sed 's/^v//')
}
package() {
- cd "$pkgname"
- install -Dm755 stl -t "$pkgdir/usr/bin"
+ cd "$srcdir/$pkgname"
+ install -Dm755 stl -t "$pkgdir/usr/bin"
- install -d "$pkgdir/usr/share/doc/${pkgname%-git}"
- cp -r *.md sbs tweaks "$pkgdir/usr/share/doc/${pkgname%-git}"
+ install -d "$pkgdir/usr/share/$pkgname"
+ cp -r sbs tweaks "$pkgdir/usr/share/$pkgname"
+
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
}