summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authororhun2020-09-19 01:09:52 +0300
committerorhun2020-09-19 01:09:52 +0300
commitc9bc11fc3e941f3d3907384ae09730e79df8fc3a (patch)
tree8d16809199eea9408f60273cdd55c77a29998ada /PKGBUILD
downloadaur-c9bc11fc3e941f3d3907384ae09730e79df8fc3a.tar.gz
Initial upload: stegano-git 0.3.2.r2.g7684f82-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea3439c198f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=stegano-git
+pkgver=0.3.2.r2.g7684f82
+pkgrel=1
+pkgdesc="CLI tool for steganography. Supports hiding data in PNG images via LSB Encoding. (git)"
+arch=('x86_64')
+url="https://github.com/steganogram/stegano-rs"
+license=('GPL3')
+makedepends=('cargo' 'git')
+conflicts=("${pkgname%-git}")
+source=("git+${url}")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}-rs"
+ git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname%-git}-rs/${pkgname%-git}-cli"
+ cargo build --release --locked
+}
+
+package() {
+ cd "${pkgname%-git}-rs"
+ install -Dm 755 "target/release/${pkgname%-git}" -t "${pkgdir}/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/${pkgname%-git}"
+}