summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNazar Mishturak2018-12-12 17:42:17 +0200
committerNazar Mishturak2018-12-12 17:42:17 +0200
commitbae9c834a577af164d2449584510683f2bbbd0d9 (patch)
tree4a2e3c8c1ce3fe03dcbb099a280f9e462fbad53d /PKGBUILD
downloadaur-bae9c834a577af164d2449584510683f2bbbd0d9.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47d8c8319d58
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Nazar Mishturak <nazarmx@gmail.com>
+_binname=step-ca
+pkgname=$_binname-bin
+pkgver=0.8.1
+pkgrel=1
+pkgdesc="An online certificate authority and related tools for secure automated certificate management, so you can use TLS everywhere."
+arch=('x86_64')
+url="https://smallstep.com/certificates"
+license=('Apache')
+
+source=("https://github.com/smallstep/certificates/releases/download/v${pkgver}/step-certificates_${pkgver}_linux_amd64.tar.gz")
+sha256sums=('38e51389ab91457f3417e702ad5ff4a8d5f176056396e49e5ae5ed88cc50a227')
+
+package() {
+ install -Dm755 "step-certificates_$pkgver/bin/$_binname" "$pkgdir/usr/bin/$_binname"
+ install -Dm644 "step-certificates_$pkgver/README.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
+}