summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDeimos2018-09-29 13:07:20 -0400
committerDeimos2018-09-29 13:07:20 -0400
commit78949cd295c5d072f664f835498809c772e2fe2b (patch)
tree40371eee43853bbf586d5e7773f712528959148b /PKGBUILD
downloadaur-78949cd295c5d072f664f835498809c772e2fe2b.tar.gz
Stage for AUR
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..cfaf67399812
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Icarus Mitchellson <mumei AT airmail DOT cc>
+
+_pkgname=StepSync
+pkgname=stepsync.app
+pkgrel=1
+pkgver=1.0
+pkgdesc='A a file and folder synchronization tool'
+arch=('i686' 'x86_64' 'armv7h')
+url='http://gap.nongnu.org/stepsync/index.html'
+license=('GPL')
+groups=('gnustep-apps')
+depends=('gnustep-base' 'gnustep-gui' 'gnustep-back')
+makedepends=('gcc-objc' 'gnustep-make')
+source=("http://savannah.nongnu.org/download/gap/StepSync-1.0.tar.gz")
+sha256sums=('97ccd23828280ba54235240413718bb96c7403763709848ef327e3cb93e39d38')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ export GNUSTEP_MAKEFILES="$(gnustep-config --variable=GNUSTEP_MAKEFILES)"
+ make
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+}