summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKazuo Teramoto2018-02-26 16:53:24 -0300
committerKazuo Teramoto2018-02-26 16:53:24 -0300
commit7fbc41243477bde5faef3cba6794091d83024162 (patch)
tree5f2285b7facdc81009d59a2ecb38090b467e45f9 /PKGBUILD
parentcf4b0d3687dd55d626885f88baf8ea94e824cd12 (diff)
downloadaur-7fbc41243477bde5faef3cba6794091d83024162.tar.gz
Change the version of urwidtrees in setup.py to >=1.0.2
The urwidtrees upstream official current release is 1.0.2, the one in pypi is an untagged release. For stig the only reason to use the 1.0.3dev0 is because of a packaging bug fixed in the git master of urwidtrees and pip, this don't affect us. This allow the use of the community/python-urwidtrees or the versions in aur. References: https://github.com/pazz/urwidtrees/issues/37 https://github.com/rndusr/stig/pull/7#issuecomment-275389365
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 01f7c1ef6ccb..9e9265b7a6e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=('stig-git')
pkgname=('stig-git')
-pkgver=0.8.2a.r91.c28fd6b
+pkgver=0.8.3a.r97.71ee76c
pkgrel=1
pkgdesc='TUI and CLI client for the Transmission daemon'
url='https://github.com/rndusr/stig'
@@ -23,6 +23,11 @@ pkgver() {
printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/^v//')"
}
+prepare(){
+ cd stig
+ sed -i 's/urwidtrees>=1.0.3dev0/urwidtrees>=1.0.2/' setup.py
+}
+
build() {
cd stig
python setup.py build
@@ -32,3 +37,4 @@ package() {
cd stig
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}
+