summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzoe2017-10-26 13:23:33 +0200
committerzoe2017-10-26 13:23:33 +0200
commit9e35222b85af1858bae6b77af63765c38bf7a430 (patch)
treec29a5b6b2b2e34a8034ad685b455fd04c39f9a5c /PKGBUILD
downloadaur-9e35222b85af1858bae6b77af63765c38bf7a430.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a165cad3301
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: zoe <chp321 AT gmail DOT com>
+
+pkgname=stitch-scanned-images
+pkgver=0.1
+pkgrel=1
+pkgdesc="automatically stitches a set of high resolution scanned segments of a large document, e.g. map, producing a near-seamless output"
+arch=(any)
+url="https://github.com/mpetroff/stitch-scanned-images"
+license=("MIT License")
+depends=('python>=3.2' 'hugin' 'imagemagick' )
+source=("${pkgname}.git::git+https://github.com/mpetroff/${pkgname}.git")
+md5sums=(SKIP)
+
+package() {
+ mkdir -p ${pkgdir}/usr/share/doc/
+ install -D -m 0755 ${srcdir}/${pkgname}.git/${pkgname}.py \
+ $pkgdir/usr/bin/${pkgname}
+ install -D -m 0644 ${srcdir}/${pkgname}.git/readme.md \
+ $pkgdir/usr/share/doc/${pkgname}.md
+}