summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpzl2015-08-08 11:55:13 -0400
committerpzl2015-08-08 11:55:13 -0400
commite7bc088109539eb607da05d84ca72ee37ab7526e (patch)
tree48340439a1f770953c729f87af3082790418be91 /PKGBUILD
downloadaur-e7bc088109539eb607da05d84ca72ee37ab7526e.tar.gz
move this package into aur4/git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0568cdb62906
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: pzl <alsoelp@gmail.com>
+# Contributor: Diego <cdprincipe@at@gmail@dot@com>
+# Contributor: Frikilinux <frikilinux@gmail.com.ar>
+
+_pkgname=stitchy
+pkgname=stitchy-git
+pkgver=7610be8
+pkgrel=1
+pkgdesc="Cross stitch pattern designer."
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('qjson')
+makedepends=('git')
+url="https://github.com/segfault87/stitchy"
+install=stitchy.install
+source=(git://github.com/segfault87/stitchy.git
+ stitchy.desktop)
+md5sums=('SKIP'
+ '126841e4b1ff8c8ab949b6be1b2a801c')
+
+
+pkgver() {
+ cd $srcdir/$_pkgname
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd $srcdir/$_pkgname
+ qmake-qt4
+ make
+}
+
+package() {
+ cd $srcdir/$_pkgname
+ install -Dm755 stitchy "$pkgdir/usr/bin/stitchy"
+ install -Dm644 $srcdir/stitchy.desktop "${pkgdir}/usr/share/applications/stitchy.desktop"
+ install -Dm644 $srcdir/stitchy/icons/fallback/stitch-full.png "${pkgdir}/usr/share/pixmaps/stitchy.png"
+}
+