summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKarsten Pufahl2022-07-22 10:09:21 +0200
committerKarsten Pufahl2022-07-22 10:09:21 +0200
commit2dc69c89860af7676517c3751a3ea1b204f80d7b (patch)
tree47a0b9973a8c421f34366e074b2e460e095dccc5 /PKGBUILD
parent287f66e523595829866b72b5f9ed69bf4ae6ffb2 (diff)
downloadaur-2dc69c89860af7676517c3751a3ea1b204f80d7b.tar.gz
launch with archlinux-java-run
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b39125f0106f..5e68437aabf9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: laserK <echo 'Y29udGFjdEBrYXJzdGVucHVmYWhsLmRlCg==' | base64 -d>
pkgname=stm32cubemx
pkgver=6.6.1
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="graphical software configuration tool for STM32 microcontrollers that allows generating C initialization code"
arch=(any)
@@ -9,7 +9,8 @@ url="https://www.st.com/en/development-tools/stm32cubemx.html"
license=('custom')
groups=()
depends=('java-runtime=11'
- 'bash')
+ 'archlinux-java-run'
+ 'bash')
makedepends=('imagemagick')
checkdepends=()
optdepends=()
@@ -21,21 +22,20 @@ options=(!strip)
install=
changelog=
source=("https://sw-center.st.com/packs/resource/library/stm32cube_mx_v${pkgver//./}-lin.zip"
- "LICENSE"
"stm32cubemx.desktop"
"stm32cubemx.sh")
noextract=()
sha512sums=('273ca4e96972cae1cf1b95eaf5dd8d6bc747149e8794fae96ff51301bfd212fbef41c306264d9b5d8c000e85d8c26d40125b4f79b18642de23b3bec24e9c9837'
'ad1897ea5234b712d726b5d3423f05f1c0c5a64e28354afe07dce7451563ae4492366cc252ca379b44793797be20011a66458431fd5453c18a7543ccb8df5397'
'56bff32e35f8eb09ae4df94e4e885aaf9349c687ce9f4901ddd11c83b69a32b19d99ab8dbd90c6679e86e7213c4d41640e52ab0d80b8fc4640a1bc5df9a3af32'
- '99ed513b6813135a3e4ee8f2a9c6e061b4fb5edddbcffcd81eca6ee8ac7fe23f804870a4aa168d83bb6902cde41f28cab0a4fa65e467ce25eb6240f701672694')
+ '6a79222fecdd4e0321d4a460a746d704c25fa32a97fd6653adfb64447053b8985c9533caf2f92f8907ef4424aa19ce0bdff3911bbdc6bf744bb354baaa3d834c')
validpgpkeys=()
package() {
cd "${srcdir}"
mkdir -p "${pkgdir}/opt/stm32cubemx"
cp -r "${srcdir}/MX/." "${pkgdir}/opt/stm32cubemx"
- install -Dm 755 "${srcdir}/stm32cubemx.sh" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm 755 "${srcdir}/stm32cubemx.sh" "${pkgdir}/usr/bin/${pkgname}"
#icon and desktop file
convert "${srcdir}/MX/help/STM32CubeMX.ico[0]" "${srcdir}/MX/${pkgname}.png"
install -Dm 644 "${srcdir}/MX/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"