summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrey Tkachenko2015-10-05 17:21:01 +0300
committerAndrey Tkachenko2015-10-05 17:21:59 +0300
commitf91a8a7b4bc1a9bf8c6aad27212045fa8efddecd (patch)
tree1caf5158f610a58474336cc0401a164ecce571df /PKGBUILD
downloadaur-f91a8a7b4bc1a9bf8c6aad27212045fa8efddecd.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86f172b854b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Andrey Tkachenko <andreytkachenko64@gmail.com>
+
+_pkgname=stm32flash
+pkgname=stm32flash-git
+pkgver=r3.c32b4c9
+pkgrel=1
+pkgdesc='Open source flash program for the STM32 ARM processors using the ST serial bootloader over UART or I2C'
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
+url='https://github.com/ARMinARM/stm32flash'
+license=('GPLv2')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+https://github.com/ARMinARM/stm32flash.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $_pkgname
+ make
+}
+
+package() {
+ # executable
+ cd $_pkgname
+ install -Dm755 $_pkgname "$pkgdir/usr/bin/$_pkgname"
+}