summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2019-09-07 18:09:12 +0200
committerChristopher Arndt2019-09-07 18:09:12 +0200
commitf7b254ca154223df59a2ab0641224e0273338405 (patch)
tree6219fdb688f004efcf7f84650d06ab93248eccc2 /PKGBUILD
parent6ab2ea2063bbacb958ef5f0efbaf3758a55470c8 (diff)
downloadaur-f7b254ca154223df59a2ab0641224e0273338405.tar.gz
New upstream version 0.1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7ca0091b6bd9..a7752e2804cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,24 @@
# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
pkgname=stone-phaser
-pkgver=0.1.0
+pkgver=0.1.1
pkgrel=1
pkgdesc="A classic analog phaser effect LADSPA, LV2 and VST2 plugin"
arch=('i686' 'x86_64')
url="https://github.com/jpcima/stone-phaser"
license=('Boost')
-# TODO: next release will probably include UI depending on cairo and mesa (headers only)
-#depends=('cairo')
-#makedepends=('mesa')
+depends=('cairo')
+makedepends=('mesa')
#optdepends=('mod-host: for using the MOD pedal GUI')
groups=('pro-audio' 'ladspa-plugins' 'lv2-plugins' 'vst-plugins')
-source=("https://github.com/jpcima/stone-phaser/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz"
- 'https://raw.githubusercontent.com/jpcima/stone-phaser/master/resources/patch/DPF-bypass.patch')
-sha256sums=('8d0e9422125c0a6a2515a2a536f835c08b150fd90d261cf9c1ee86668b3e70bd'
- 'c9f7c7312d459da55f8291bd403449b893862533bcf92d9a4f3c23a10df781c5')
+source=("https://github.com/jpcima/stone-phaser/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('7fd1b688c1ddb0d350028bec6141fedde7ec523354681adc4548b32be132c882')
-# TODO: next release will probably include LV2 UI needing this patch
-#prepare() {
-# cd "${srcdir}/${pkgname}-${pkgver}/dpf"
-# patch -N -r - -p 1 -i "${srcdir}"/DPF-bypass.patch || return 0
-#}
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}/dpf"
+ patch -N -r - -p 1 -i ../resources/patch/DPF-bypass.patch
+}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"