summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVinicius Correa2019-11-19 10:40:07 -0300
committerVinicius Correa2019-11-19 10:40:07 -0300
commite553231d8d2b7234028795396f3c0f593667cb7f (patch)
treeeb08996f2a0ccda4e68acdca31f028ad92e553af /PKGBUILD
downloadaur-e553231d8d2b7234028795396f3c0f593667cb7f.tar.gz
v0.26.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99e033a21766
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Vinicius Correa <vinicius.correa at zoho dot com>
+
+pkgname=stoqserver
+pkgver=0.26.1
+pkgrel=1
+pkgdesc="A server for Stoq"
+arch=('any')
+url="https://www.stoq.com.br"
+license=('GPL')
+depends=('python' 'python-flask' 'python-flask-restful' 'python-gevent' 'python-netifaces' 'python-requests' 'python-twisted' 'postgresql')
+install=${pkgname}.install
+source=("https://pypi.python.org/packages/source/s/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('66dd7c7a83b21e0138e28c38f27fe45c')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}