summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Shalygin2024-03-19 15:11:32 +0700
committerKonstantin Shalygin2024-03-19 15:11:32 +0700
commit672f1709df58c744d303174669b1936dafd26a16 (patch)
tree9cd76b79d78da947f14411cb9614b1129cd22284 /PKGBUILD
parent6782888851b893302a376f3a571d93dabad5c32f (diff)
downloadaur-672f1709df58c744d303174669b1936dafd26a16.tar.gz
Fixes for aarch64
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f38d965ab270..5485fd7a2564 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname='storcli'
_name='STORCLI_SAS3.5_P'
pkgver='007.2904.0000.0000'
-pkgrel='1'
+pkgrel='2'
_phase='30'
pkgdesc="CLI program for LSI MegaRAID cards"
url='https://www.broadcom.com/'
@@ -14,12 +14,11 @@ makedepends=('libarchive')
source=("https://docs.broadcom.com/docs-and-downloads/host-bus-adapters/host-bus-adapters-common-files/sas_sata_nvme_12g_p${_phase}/${_name}${_phase}.zip")
sha256sums=('dafaa8ae83aae9c50ddfbfb86321b91d1eba36357eb33009c25776e2efe75519')
-_variant_aarch64='ARM/Linux'
-_variant_x86_64='Linux'
-_archstr=$([[ "${CARCH}" == 'x86_64' ]] && echo -n "${_variant_x86_64}" || echo -n "${_variant_aarch64}")
+_archstr=$([[ "${CARCH}" == 'x86_64' ]] && echo -n "Linux" || echo -n "ARM/Linux")
+_filearch=$([[ "${CARCH}" == 'x86_64' ]] && echo -n "noarch" || echo -n "${CARCH}")
prepare() {
- bsdtar -xf "${_name}${_phase}/univ_viva_cli_rel/Unified_storcli_all_os/${_archstr}/${pkgname}-${pkgver}-${pkgrel}.noarch.rpm"
+ bsdtar -xf "${_name}${_phase}/univ_viva_cli_rel/Unified_storcli_all_os/${_archstr}/${pkgname}-${pkgver}-1.${_filearch}.rpm"
}
package() {