summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKyle Manna2015-08-25 14:56:06 -0700
committerKyle Manna2015-08-25 14:56:06 -0700
commit76b306a25019ef072558b4953d44a8b0d4cfa3e1 (patch)
treed64223337d9575e0053348b460c35bab5881deaf /PKGBUILD
parentac209d00a1c218bbfa2fd9602751d01f6e7f74e8 (diff)
downloadaur-76b306a25019ef072558b4953d44a8b0d4cfa3e1.tar.gz
PKGBUILD: Bump to v1.3.0
* Follow-upstream * Add new python-partialhash dependency * Clean-up mess made with test files being installed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 14458f6cf11a..50428e8e2aed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Kyle Manna <kyle[at]kylemanna[d0t]com>
pkgname=storj-dataserv-client
_pkgname=${pkgname/storj-/}
-pkgver=1.1.0
-pkgrel=2
+pkgver=1.3.0
+pkgrel=1
pkgdesc="Storj Client for storing and auditing data"
url="https://github.com/Storj/dataserv-client"
-depends=('python' 'python-pip' 'python-future' 'python-randomio')
+depends=('python' 'python-pip' 'python-future' 'python-randomio' 'python-partialhash')
optdepends=()
license=('MIT')
arch=('any')
source=("https://github.com/Storj/${_pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('d454a110484857dd2ba4103b3b09a5fab8cf38bbe1e16d95f63032b2c9f80cbe')
+sha256sums=('f2f4761f9e372fd4b85136238910185bd0ff44021905debbbdab083c6968e353')
build() {
cd "$srcdir/$_pkgname-$pkgver"
@@ -20,5 +20,6 @@ build() {
package() {
cd "$srcdir/$_pkgname-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
+ rm -rf ${pkgdir}/usr/lib/python3.4/site-packages/tests/
}