summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKyle Manna2015-08-12 11:06:40 -0700
committerKyle Manna2015-08-12 11:08:47 -0700
commitfb0cd0dd9655a738ce02aa20ff30adf054b89f68 (patch)
tree741da78d2e92dee08c6a1a7cee47c7e94cf6245c /PKGBUILD
downloadaur-fb0cd0dd9655a738ce02aa20ff30adf054b89f68.tar.gz
PKGBUILD: First commit
* First attempt at making storj package. * Hide the cruft with gitignore.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02e4f857688c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Kyle Manna <kyle[at]kylemanna[d0t]com>
+pkgname=storj-dataserv-client
+_pkgname=${pkgname/storj-//}
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Storj Client for storing and auditing data"
+url="https://github.com/Storj/dataserv-client"
+depends=('python' 'python-pip')
+optdepends=()
+license=('MIT')
+arch=('any')
+source=("https://github.com/Storj/${_pkgname}/archive/v1.1.0.tar.gz")
+sha256sums=('d454a110484857dd2ba4103b3b09a5fab8cf38bbe1e16d95f63032b2c9f80cbe')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+