summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM. Nabil Adani2021-04-10 21:23:54 +0700
committerM. Nabil Adani2021-04-10 21:23:54 +0700
commitc67abe18a91dcadac4f349f953377ec5dd13fa3d (patch)
treebd49b5db60860d62d9ab7e59a4ace9dc240af6e0 /PKGBUILD
downloadaur-c67abe18a91dcadac4f349f953377ec5dd13fa3d.tar.gz
stable release 1.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aebed45ef0cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Yunindyo Prabowo <dyo.ndutz@gmail.com>
+# Contributor: Muhammad Nabil Adani <nblid48@gmail.com>
+
+pkgname=stowtui-git
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='stow tui is a Terminal User Interface Program for GNU STOW'
+arch=('any')
+url="https://github.com/ypraw/stowtui/"
+license=('GPLv3')
+makedepends=('python-setuptools')
+depends=('python' 'python-pygments' 'python-wcwidth' 'python-npyscreen')
+source=("${pkgname}::git+https://github.com/ypraw/stowtui.git")
+sha256sums=('SKIP')
+
+package() {
+ cd "$srcdir/$pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+