summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGustavo Costa2021-09-04 03:37:17 -0300
committerGustavo Costa2021-09-04 03:37:17 -0300
commit0aa48a084743cf69e78af8a6309225902f3dd118 (patch)
tree8a3ab6809e8d0c0fdae0f41e53b06c46dad8c11a /PKGBUILD
downloadaur-0aa48a084743cf69e78af8a6309225902f3dd118.tar.gz
Initial package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a94fbc9c2933
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Gustavo Costa <xfgusta@gmail.com>
+
+pkgname=strace-with-colors
+_pkgname=strace
+pkgver=5.14
+pkgrel=1
+pkgdesc='A diagnostic, debugging and instructional userspace tracer (with colors)'
+arch=(x86_64)
+url='https://strace.io/'
+license=(BSD)
+depends=(perl libunwind)
+makedepends=(git)
+conflicts=($_pkgname)
+provides=($_pkgname)
+source=("https://github.com/strace/strace/releases/download/v$pkgver/strace-$pkgver.tar.xz"
+ "$pkgname.patch")
+sha1sums=('6625b01b18c3940cd926c85e4d1feb10f162973d'
+ 'SKIP')
+
+prepare() {
+ cd $_pkgname-$pkgver
+ git apply "${srcdir}/$pkgname.patch"
+}
+
+build() {
+ cd $_pkgname-$pkgver
+ ./configure --prefix=/usr --with-libunwind --enable-mpers=no
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}