summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhexptr2020-07-18 19:13:09 +0100
committerhexptr2020-07-18 19:13:09 +0100
commitb15a179788b0231638fca9ce9d264977db7e9256 (patch)
tree7baa5ec9dd7830d50c070d7105bd9f5816d1b152 /PKGBUILD
downloadaur-b15a179788b0231638fca9ce9d264977db7e9256.tar.gz
initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd1f904573a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: hexptr <hexptr@protonmail.com>
+pkgname=streamdeck-ui-git
+_pkgname=streamdeck-ui
+pkgver=r102.96f2305
+pkgrel=1
+pkgdesc="A Linux compatible UI for the Elgato Stream Deck"
+arch=('any')
+url="https://timothycrosley.github.io/streamdeck-ui/"
+license=('MIT')
+depends=('python-pillow' 'python-hidapi' 'pyside2' 'python-pynput' 'python-elgato-streamdeck')
+makedepends=('git' 'python-dephell' 'python-setuptools')
+provides=('streamdeck-ui')
+source=("git+https://github.com/timothycrosley/streamdeck-ui.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$_pkgname"
+ dephell deps convert --from pyproject.toml --to setup.py
+}
+
+build() {
+ cd "$_pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$_pkgname"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}