summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosip Ponjavic2016-12-06 11:51:00 +0100
committerJosip Ponjavic2016-12-06 11:51:00 +0100
commit41029e22fb5365885637bb12bdfb2bb0f1ec0b3d (patch)
tree8d4a2da4617e8bc46c422877780b6a82aee9ae87 /PKGBUILD
parentf4a35e39a0cd70f48b16a4e9e9010fd592f6a24a (diff)
downloadaur-41029e22fb5365885637bb12bdfb2bb0f1ec0b3d.tar.gz
Remove requests sed line, add check section python-pytest
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 27fcf5a32a93..dd306948a361 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
pkgname=streamlink-git
-pkgver=0.1.0.r20.g2808eb6
+pkgver=0.1.0.r35.g2b052ad
pkgrel=1
pkgdesc='CLI program that launches streams from various streaming services in a custom video player (livestreamer fork)'
arch=('any')
url='https://streamlink.github.io/'
license=('BSD')
depends=('python-pycryptodome' 'python-requests' 'python-setuptools' 'rtmpdump')
+checkdepends=('python-pytest')
makedepends=('git' 'python-sphinx')
optdepends=('python-librtmp: Required by the ustreamtv plugin to be able to use non-mobile streams.')
provides=('streamlink')
@@ -22,10 +23,14 @@ pkgver() {
build() {
cd streamlink
- sed -i 's/requests>=1.0,<2.12.0/requests>=1.0,<3.0/' setup.py
python setup.py build_sphinx -b man
}
+check() {
+ cd streamlink
+ python -m pytest tests/
+}
+
package() {
cd streamlink
python setup.py install --root="$pkgdir" --optimize=1