summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosip Ponjavic2021-10-19 23:34:36 +0200
committerJosip Ponjavic2021-10-19 23:34:36 +0200
commitf9859ceec403a50621951c5f9699e57284ef6418 (patch)
tree47030a4b0b2b3b5bd58a80068aded5fdf6deabbd /PKGBUILD
parentfa01aaf4042c9b0b11514c69230e56bc0e971460 (diff)
downloadaur-f9859ceec403a50621951c5f9699e57284ef6418.tar.gz
upgpkg: 2.4.0.r53.g765f969d-1 fix tests
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ecd2a9b99e8..da345fdd5fa2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
pkgname=streamlink-git
-pkgver=2.2.0.r34.gd04767fa
+pkgver=2.4.0.r53.g765f969d
pkgrel=1
pkgdesc='CLI program that launches streams from various streaming services in a custom video player (livestreamer fork)'
arch=('any')
@@ -30,7 +30,9 @@ build() {
check() {
cd "${pkgname%-*}"
- python setup.py test
+ pyver=$(python -c "import sys; print('{}.{}'.format(*sys.version_info[:2]))")
+ python setup.py install --root="$PWD/tmp_install" --skip-build
+ PYTHONPATH="$PWD/tmp_install/usr/lib/python$pyver/site-packages" pytest
}
package() {