summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbastimeyer2020-12-07 21:39:19 +0100
committerbastimeyer2020-12-07 21:39:19 +0100
commit78de83d66211f10826804d5f6412c89c40357276 (patch)
tree07b4f561aee215b9ee4b2af75cf450ababe04ec0 /PKGBUILD
parente8513401d1be63f5c8c7108b5be79929368be4a2 (diff)
downloadaur-78de83d66211f10826804d5f6412c89c40357276.tar.gz
Add xorg-server-xvfb make dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 62612a514109..ae8e4227d1ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ license=("MIT")
provides=("${_pkgname}")
conflicts=("${_pkgname}")
depends=("gtk3" "libxss" "nss" "streamlink")
-makedepends=("git" "nodejs" "yarn")
+makedepends=("git" "nodejs" "yarn" "xorg-server-xvfb")
options=(!strip)
source=("${_pkgname}::git+https://github.com/streamlink/${_pkgname}.git")
sha256sums=("SKIP")
@@ -28,7 +28,7 @@ prepare() {
check() {
cd "${srcdir}/${_pkgname}"
- yarn run test
+ xvfb-run --auto-servernum yarn run test
}
build() {