summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorl422020-12-26 20:11:04 +0500
committerl422020-12-26 20:11:04 +0500
commit231b88740c4ed794756ff85a80808550384fcc84 (patch)
treedd22601d58f5722e410b99d745a2ea2d687ac7e6 /PKGBUILD
parent6ace5be35b274926451134abcef109e2b6e83a38 (diff)
downloadaur-231b88740c4ed794756ff85a80808550384fcc84.tar.gz
Add aarch64 build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 29bfb02d7d17..ca9a49838dbd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,19 +5,21 @@ pkgver=1.4.0
pkgrel=1
_rlsver=v1.4.0
pkgdesc="The break time reminder app"
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://github.com/hovancik/stretchly/"
license=('BSD')
provides=('stretchly')
conflicts=('stretchly')
depends=('c-ares' 'ffmpeg' 'gtk3' 'http-parser' 'libevent' 'libvpx' 'libxslt' 'libxss' 'minizip' 'nss' 're2' 'snappy' 'libnotify' 'libappindicator-gtk3')
install=${_pkgname}.install
-source=(
- "https://github.com/hovancik/stretchly/releases/download/$_rlsver/$_pkgname-$pkgver.pacman"
- "LICENSE::https://raw.githubusercontent.com/hovancik/stretchly/$_rlsver/LICENSE"
-)
-sha256sums=('baa55f75fda425832ef9753df705731f0200ec348d4e4eb3ce528a16acd45da4'
- 'd4262f71a6c02b19bdbdf760033803c0c7ca24acf2591ba425633f7e3315790a')
+
+source=("LICENSE::https://raw.githubusercontent.com/hovancik/stretchly/$_rlsver/LICENSE")
+source_x86_64=("https://github.com/hovancik/stretchly/releases/download/$_rlsver/$_pkgname-$pkgver.pacman")
+source_aarch64=("https://github.com/hovancik/stretchly/releases/download/$_rlsver/$_pkgname-$pkgver-arm64.pacman")
+
+sha256sums=('d4262f71a6c02b19bdbdf760033803c0c7ca24acf2591ba425633f7e3315790a')
+sha256sums_x86_64=('baa55f75fda425832ef9753df705731f0200ec348d4e4eb3ce528a16acd45da4')
+sha256sums_aarch64=('9638956a856b4ba195ad5916fd0640def964c6d6423dd13980038c1df2da2c7e')
package() {
# copy binaries to fakeroot