summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxeruf2023-07-03 21:49:56 +0200
committerxeruf2023-07-03 21:49:56 +0200
commit6e3356a25cd35ecc719ca8194b0ccd00cef55cbd (patch)
tree16ec088adf1f17a4c4eb0d1b9b8b1099d3f222ae /PKGBUILD
parent33211555a66d125f3924df5c85ae9f2a3d40a21e (diff)
downloadaur-stretchly-xeruf-git.tar.gz
Fix build when prepare and build are run separately
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6704ca702f28..aa2a3fd44f7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,12 +29,12 @@ _ensure_local_nvm() {
unset npm_config_prefix
export NVM_DIR=${srcdir}/.nvm
. /usr/share/nvm/init-nvm.sh
+ _node_version=$(jq -r '.engines.node' package.json)
}
prepare() {
cd "${srcdir}/${_pkgname}"
_ensure_local_nvm
- _node_version=$(jq -r '.engines.node' package.json)
# ` || false` is a workaround until this upstream fix is released:
# https://github.com/nvm-sh/nvm/pull/2698
nvm ls "$_node_version" &>/dev/null ||