summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStijn Seghers2020-05-03 18:30:41 +1200
committerStijn Seghers2020-05-03 18:30:41 +1200
commitf57a8342740196c11ecf67656425d07787f55243 (patch)
tree0cb62ab05e4a51cf425051eee8169f359ab1db28 /PKGBUILD
parentda8d9cd68cf4a36a43687bcebe765383252b2998 (diff)
downloadaur-stylelint.tar.gz
Bump version to 13.3.3 and ensure correct file ownership & permissions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0905a1be7eba..716278d9a6c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Stijn Seghers <stijnseghers at gmail dot com>
pkgname=stylelint
-pkgver=13.2.1
+pkgver=13.3.3
pkgrel=1
-pkgdesc='A mighty, modern linter that helps you avoid errors and enforce conventions in your styles'
+pkgdesc='A linter for CSS-like syntaxes like SCSS, Sass, Less and SugarSS'
arch=('any')
url='https://stylelint.io/'
license=('MIT')
@@ -12,14 +12,19 @@ optdepends=('stylelint-config-standard: config for common conventions')
makedepends=('npm')
source=("https://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz")
noextract=("$pkgname-$pkgver.tgz")
-sha256sums=('d546f244aa67e0b321ae577be50263707589509819b8c479c74cecf1c21491fc')
+sha256sums=('7691a41622514d9b8298511907c7b58e5d83aeeba63482481706c21294d34085')
package() {
- npm install -g --prefix "$pkgdir/usr" "$srcdir/$pkgname-$pkgver.tgz"
+ npm install -g --user root --prefix "$pkgdir/usr" "$srcdir/$pkgname-$pkgver.tgz"
- # For some odd reason, npm makes some directories world writeable D:
+ # Non-deterministic race in npm gives 777 permissions to random directories.
+ # See https://github.com/npm/npm/issues/9359 for details.
find "$pkgdir/usr" -type d -exec chmod 755 {} +
+ # npm gives ownership of ALL FILES to build user
+ # https://bugs.archlinux.org/task/63396
+ chown -R root:root "$pkgdir"
+
# Install license in the usual place
local _npmdir="$pkgdir/usr/lib/node_modules/"
install -Dm644 "$_npmdir/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"