summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStijn Seghers2017-04-09 11:02:06 +1200
committerStijn Seghers2017-04-09 11:02:06 +1200
commit5e5f455e8888c8c375411b9ef5f7f5c93ca3fc07 (patch)
treef49b503ec6137811620f9301f4a04cb65d00eda5 /PKGBUILD
downloadaur-5e5f455e8888c8c375411b9ef5f7f5c93ca3fc07.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af3dc749e73b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Stijn Seghers <stijnseghers at gmail dot com>
+
+pkgname=stylelint
+pkgver=7.10.1
+pkgrel=1
+pkgdesc='A mighty, modern CSS linter that helps you enforce consistent conventions and avoid errors in your stylesheets'
+arch=('any')
+url='https://stylelint.io/'
+license=('MIT')
+depends=('nodejs')
+optdepends=('stylelint-config-standard')
+makedepends=('npm')
+source=("http://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz")
+noextract=("$pkgname-$pkgver.tgz")
+sha512sums=('b5e56c3ca9f729f8b3c63539f50fbbbe0f3c9bbab7089001f409edfd44ebb794b96b6a5052cddbe37f6096b677449b9dc5192f20906d04ed473b2475d9cb9a12')
+
+package() {
+ npm install -g --user root --prefix "$pkgdir/usr" "$srcdir/$pkgname-$pkgver.tgz"
+
+ rm -r "$pkgdir/usr/etc"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "../../../lib/node_modules/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}