summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052023-10-19 15:22:22 +0800
committerzxp198210052023-10-19 15:22:22 +0800
commitf3a3068575789193a428cb34099deb29e7bba7ff (patch)
treec17cc0c32be95ad689ea3ee36e3cf59a1811b1fa /PKGBUILD
downloadaur-f3a3068575789193a428cb34099deb29e7bba7ff.tar.gz
update to 0.3.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8ffa92a7575
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=sub-trans-bin
+_pkgname="Panfu Desktop"
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="A GUI tool swap subtitle between tchinese and schinese"
+arch=("x86_64")
+url="https://github.com/dreamfliper/subTrans"
+license=('unknown')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=('cairo' 'dbus' 'pango' 'glibc' 'gcc-libs' 'gtk3' 'openssl' 'glib2' 'webkit2gtk' 'gdk-pixbuf2' 'hicolor-icon-theme')
+source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb")
+sha256sums=('14cb85606b6a01cf7a4bae02dc646fc0947bc9aada5debbfac5e07977d320a56')
+build() {
+ bsdtar -xf "${srcdir}/data.tar.gz"
+}
+package() {
+ install -Dm755 "${srcdir}/usr/bin/${pkgname%-bin}" -t "${pkgdir}/usr/bin"
+ install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ for _icons in 16x16 32x32 128x128 256x256 512x512;do
+ install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
+ -t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
+ done
+} \ No newline at end of file