summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpusi772023-03-07 21:36:54 +0100
committerpusi772023-03-07 21:36:54 +0100
commit073ab402c001358617f5c9887473dfbe13049c51 (patch)
tree00c99869104a24bbcd32b99379ff10a0e5be511b /PKGBUILD
downloadaur-073ab402c001358617f5c9887473dfbe13049c51.tar.gz
added subdomainizer
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac6047497f14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: pusi77 <pusineriandrea+gmail+com>
+
+pkgname=subdomainizer
+pkgver=2.0
+pkgrel=1
+pkgdesc="A tool to find subdomains and interesting things hidden inside, external Javascript files of page, folder, and Github."
+arch=(any)
+url="https://github.com/nsonaniya2010/SubDomainizer"
+license=(MIT)
+depends=(python-termcolor python-argparse python-beautifulsoup4 python-requests python-htmlmin python-tldextract python-colorama python-cffi)
+source=(https://github.com/nsonaniya2010/SubDomainizer/archive/refs/tags/v${pkgver}.tar.gz)
+sha256sums=('4c0b4745d54b6797eeb5f79851bd34334187763d71459a27736904753db75d0c')
+
+build() {
+ cd SubDomainizer-${pkgver}
+ python -m compileall .
+ python -O -m compileall .
+}
+
+package() {
+ cd SubDomainizer-${pkgver}
+ install -d "${pkgdir}/opt/${pkgname}"
+ install -d "${pkgdir}/usr/bin/"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cp -a --no-preserve=ownership * "${pkgdir}/opt/${pkgname}"
+
+ cat > "${pkgdir}/usr/bin/${pkgname}" << EOF
+#!/bin/sh
+cd /opt/${pkgname}
+python SubDomainizer.py "\$@"
+EOF
+
+ chmod 755 "${pkgdir}/usr/bin/${pkgname}"
+}