summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWu Zhenyu2023-06-19 16:14:11 +0800
committerWu Zhenyu2023-06-19 16:14:11 +0800
commitb13e8bc019f4b9b84f0a44e8bee3ae205c00d0b5 (patch)
treef109662e59ec8a50d2be9ed081108d3cc6ce6696 /PKGBUILD
downloadaur-b13e8bc019f4b9b84f0a44e8bee3ae205c00d0b5.tar.gz
:tada: Initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc33ac62287f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# shellcheck shell=bash disable=SC2034,SC2154
+_pkgname=sublime-syntax-language-server
+pkgname="python-$_pkgname"
+pkgver=0.0.0
+pkgrel=1
+pkgdesc="sublime-syntax language server"
+arch=(any)
+url=https://github.com/Freed-Wu/sublime-syntax-language-server
+depends=(python-pygls python-platformdirs)
+makedepends=(python-installer)
+license=(GPL3)
+_py=py3
+source=("https://files.pythonhosted.org/packages/$_py/${_pkgname::1}/${_pkgname//-/_}/${_pkgname//-/_}-$pkgver-$_py-none-any.whl")
+sha256sums=('SKIP')
+
+package() {
+ python -m installer -d "$pkgdir" ./*.whl
+}