summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcaltlgin2020-06-17 15:30:21 +1200
committercaltlgin2020-06-17 15:30:21 +1200
commitd8eaf3e671279ea01ab320b87dbf6d83eb0d0792 (patch)
tree8d9b6314116f3a342c8822128299a1bc696c50d5 /PKGBUILD
downloadaur-d8eaf3e671279ea01ab320b87dbf6d83eb0d0792.tar.gz
Add to AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16367f84854e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+pkgname=subminder
+pkgver=1.2.0
+pkgrel=1
+pkgdesc='Keep tabs on your subscriptions'
+arch=('x86_64')
+url='https://github.com/jeremyvaartjes/subminder'
+license=('GPL3')
+depends=('granite')
+makedepends=('libsoup' 'meson' 'vala')
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=('86cacd55fbddfc248a4a79c5d11e871f3b5d117e8489b0de72a16da55510afe8')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ meson build --prefix=/usr
+ ninja -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" ninja -C "${pkgname}-${pkgver}/build" install
+ install -Dm644 "${pkgname}-${pkgver}/README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}
+
+# vim: ts=2 sw=2 et: \ No newline at end of file