summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGaetan Bisson2019-06-04 20:36:38 -1000
committerGaetan Bisson2019-06-04 20:36:38 -1000
commit19f912a13fc4eace231fa77ea542524143e75d35 (patch)
tree65b3413e96eafb2cb3baae63e286ec10a0d3b61c /PKGBUILD
parent4ef03e87309c2da615d9e2c4595d813c29aa26e0 (diff)
downloadaur-19f912a13fc4eace231fa77ea542524143e75d35.tar.gz
upstream update, fix error: expected unqualified-id before 'namespace'
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6c6f68cf8651..aa15c0c32f5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=subsurface-git
_pkgname=subsurface
-pkgver=20180621.693604753
+pkgver=20190603.a592b4e14
pkgrel=1
pkgdesc='Divelog program'
url='https://subsurface-divelog.org/'
@@ -13,8 +13,10 @@ makedepends=('git' 'cmake' 'asciidoc' 'qt5-tools')
depends=('libzip' 'libxml2' 'libxslt' 'sqlite' 'libusb' 'libgit2'
'subsurface-libdc-git' 'qt5-svg' 'qt5-location'
'qt5-connectivity' 'qt5-webkit' 'grantlee' 'googlemaps')
-source=('git+https://github.com/Subsurface-divelog/subsurface')
-sha256sums=('SKIP')
+source=('git+https://github.com/Subsurface-divelog/subsurface'
+ 'semicolon.patch')
+sha256sums=('SKIP'
+ 'ebf7a7e3690254a257ff9094a1298b7d070abe8cf95c03ea21d78ec710972060')
# qt5-webkit still used for: printing, manual, facebook
@@ -26,11 +28,13 @@ pkgver() {
git log -1 --format='%cd.%h' --date=short | tr -d -
}
-build() {
+prepare() {
cd "${srcdir}/${_pkgname}"
- git revert -n a76f15f0f67c3f138362ec8c503f645dc1211cf5
- git revert -n d21d42b69117aae04b68ecc9cc2139e034bde146
+ sudo patch /usr/include/qt/QtQml/qqmlprivate.h ../semicolon.patch
+}
+build() {
+ cd "${srcdir}/${_pkgname}"
install -d build
cd build
cmake \