summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGaetan Bisson2015-06-08 12:03:27 -1000
committerGaetan Bisson2015-06-08 12:03:27 -1000
commit41a2eb0fe0af0315c5c35f7bedae81d76f9d8912 (patch)
treec211c897011ad3c62c500cc4fd0648f1b37a5925 /PKGBUILD
downloadaur-41a2eb0fe0af0315c5c35f7bedae81d76f9d8912.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92b1165ae4c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Contributor: Francois Boulogne <fboulogne at april dot org>
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+
+pkgname=subsurface-git
+_pkgname=subsurface
+pkgver=20150607.d9801b6
+pkgrel=1
+pkgdesc='Divelog program'
+url='http://subsurface-divelog.org/'
+license=('GPL2')
+arch=('i686' 'x86_64')
+makedepends=('git' 'cmake' 'asciidoc')
+depends=('libzip' 'libxml2' 'libxslt' 'sqlite' 'libusb' 'libgit2'
+ 'subsurface-libdc' 'subsurface-marble')
+source=('git://git.subsurface-divelog.org/subsurface')
+sha1sums=('SKIP')
+
+install=install
+
+provides=('subsurface')
+conflicts=('subsurface')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DMARBLE_INCLUDE_DIR='/usr/include/subsurface' \
+ .
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+}