summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVekhir2023-01-17 05:01:19 +0100
committerVekhir2023-01-17 05:01:19 +0100
commitd0c622a46292b347c1d9960ba53e84690309d281 (patch)
treee2d4a8115bad3d72fb36639ae9828a8093ee8ed8 /PKGBUILD
downloadaur-d0c622a46292b347c1d9960ba53e84690309d281.tar.gz
Initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15c027383514
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Vekhir <vekhir AT yahoo DOT com>
+
+pkgname='subtitld'
+pkgver=22.10
+pkgrel=1
+pkgdesc='Subtitld: An open source software to create, edit and transcribe subtitles'
+arch=('x86_64')
+url='https://www.subtitld.org/'
+license=('GPLv3')
+depends=('pyside6' 'python-pyffms2' 'python-mpv'
+ 'python-opengl' 'python-numpy' 'python-cffi' 'python-requests' 'python-pycaption'
+ 'python-pysubs2' 'python-cleantext' 'python-translate' 'python-speechrecognition'
+ 'python-docx' 'python-charset-normalizer' 'python-google-api-python-client'
+ 'python-pysrt' 'python-certifi')
+makedepends=('git' 'python-setuptools')
+source=("https://gitlab.com/jonata/$pkgname/-/archive/$pkgver/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('51228b7520ce843926a799526b419939baed2a487d0bee75a6563a15aa006500')
+
+build() {
+ cd ${pkgname}-${pkgver}/
+ python setup.py build
+}
+
+package() {
+ cd ${pkgname}-${pkgver}/
+ python setup.py install --root="$pkgdir" --optimize=1
+}