summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGötz Christ2015-06-15 13:07:39 -0500
committerGötz Christ2015-06-15 13:07:39 -0500
commitd954cb6d2d901357d05f3cd3158f3ca8712e918e (patch)
treedd3ede5cf660c693b4615ad46def635aec37dd3d /PKGBUILD
downloadaur-d954cb6d2d901357d05f3cd3158f3ca8712e918e.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65f153ab01ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=subtitleeditor-svn
+pkgver=0.41.0.r887
+pkgrel=1
+pkgdesc="GTK+3 tool to create and edit subtitles."
+arch=('i686' 'x86_64')
+url="http://home.gna.org/subtitleeditor/"
+license=('GPL3')
+depends=('desktop-file-utils' 'enchant' 'gst-plugins-base' 'gst-libav' 'gstreamermm>=1.0'
+ 'gtk3' 'gtkmm3' 'hicolor-icon-theme' 'libsigc++' 'libxml++' 'xdg-utils')
+makedepends=('svn' 'intltool' 'mm-common')
+optdepends=('gst-plugins-ugly: to be able to view movies inside the subtitleeditor')
+provides=(${pkgname%-*})
+conflicts=(${pkgname%-*})
+install=${pkgname%-*}.install
+source=('subtitleeditor-svn::svn+http://svn.gna.org/svn/subtitleeditor/trunk')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ local ver="$(svnversion)"
+ printf "0.41.0.r%s" "${ver//[[:alpha:]]}"
+}
+
+build() {
+ cd ${pkgname}
+
+ sh autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname}
+
+ make DESTDIR=${pkgdir} install
+}