summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorColin Arnott2017-12-29 06:13:27 +0000
committerColin Arnott2017-12-29 06:13:51 +0000
commitfaeb9c8396d78f7239a87dc0282760f45b262808 (patch)
treeedb8b1b180007df4cd2d2b47d2f3b2955253163d /PKGBUILD
parent7cdb0c0fdae7f3c832dbe88b8f3117e3a9273ced (diff)
downloadaur-faeb9c8396d78f7239a87dc0282760f45b262808.tar.gz
bump version to 0.8.4, fix completion generation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 192141e8b0c8..9d933188f9cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Colin Arnott <colin@urandom.co.uk>
pkgname=sucks
-pkgver=0.8.3
-pkgrel=2
+pkgver=0.8.4
+pkgrel=1
pkgdesc="Simple command-line script for the Ecovacs series of robot vacuums"
arch=(any)
url="https://github.com/wpietri/sucks"
license=('GPL')
-depends=('python' 'python-sleekxmpp' 'python-click' 'python-requests' 'python-pycryptodome' 'python-pycountry-convert' 'python-pytest-mock')
+depends=('python' 'python-sleekxmpp' 'python-click' 'python-requests' 'python-pycryptodome' 'python-pycountry-convert' 'python-pytest-mock' 'python-stringcase')
checkdepends=('python-nose' 'python-requests-mock')
optdepends=('bash-completion')
source=("${url}/archive/v${pkgver}.tar.gz")
-sha512sums=('458aeda0b84a58161793c618039f21e55a143635b3786e391b907a21964e60f5215712007d039eac92b2144013ea69e0743a8db20452ea4ce8bfeeca8c23ce8d')
+sha512sums=('c5f5b429d5f9fe7dcccdd8e1d1d0589250336fde11d51d5e2093da97eda8bd0176c5e6e8db1acdd73c358eeb4ae635e2137aa3b1c98b78e28bc3e656cf91e348')
build() {
cd $pkgname-$pkgver
@@ -26,5 +26,5 @@ check() {
package() {
cd $srcdir/$pkgname-$pkgver
python setup.py install --root="$pkgdir/" --optimize=1
- #_SUCKS_COMPLETE=source $pkgdir/usr/bin/sucks | install -Dm644 /dev/stdin $pkgdir/usr/share/bash-completion/completions/sucks
+ PYTHONPATH="$pkgdir/usr/lib/python3.6/site-packages:$PYTHONPATH" _SUCKS_COMPLETE=source $pkgdir/usr/bin/sucks | install -Dm644 /dev/stdin $pkgdir/usr/share/bash-completion/completions/sucks
}