summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhbhkx2020-01-15 17:19:23 +0800
committerhbhkx2020-01-15 17:19:23 +0800
commit11275277f81973ebedddb68d2784d887103a768c (patch)
tree4aba21b0f2ab3fd395aceb0906eb528a20e60f2e /PKGBUILD
parent3f07f610cf2d13f4acfdf282d58f8eee348b2d7e (diff)
downloadaur-11275277f81973ebedddb68d2784d887103a768c.tar.gz
fix path and patching problems
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c196e7eb909..a75b0ba49d96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ gblasver=3.1.1
conflicts=('umfpack' 'graphblas' 'suitesparse')
provides=('umfpack' "graphblas=${gblasver}" "suitesparse=${pkgver}")
replaces=('umfpack' 'graphblas' 'suitesparse')
-depends=('metis' 'intel-mkl' 'intel-tbb')
+depends=('metis' 'intel-mkl' 'intel-tbb_psxe')
makedepends=('intel-compiler-base' 'intel-fortran-compiler' 'cmake')
license=('GPL')
options=()
@@ -22,16 +22,16 @@ sha1sums=('3de08b5ab02610ed0446225aad2445696616fae5'
prepare() {
# Fix linking with intel-tbb
cd ${srcdir}
- patch -p0 suitesparse-mkl_tbb.patch
+ patch -p0 < suitesparse-mkl_tbb.patch
}
build() {
- cd ${srcdir}/SuiteSparse
+ cd ${srcdir}/SuiteSparse-${pkgver}
JOBS=8 make
}
package() {
- cd ${srcdir}/SuiteSparse
+ cd ${srcdir}/SuiteSparse-${pkgver}
make install
}