summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhbhkx2020-01-15 16:54:59 +0800
committerhbhkx2020-01-15 16:54:59 +0800
commitaeb131f93204a6feaf3cba5fcc7754a31559efe2 (patch)
tree18ff7d8ed0c5a0b309d062c09851bb98423ac96e /PKGBUILD
parenta6a5f600dd2e7f2b71a9772965053b18e3692649 (diff)
downloadaur-aeb131f93204a6feaf3cba5fcc7754a31559efe2.tar.gz
update to 5.6.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0507d126f5ad..7a3bfcd96abc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,23 @@
-# Maintainer: Israel Herraiz <isra@herraiz.org>
+# Maintainer: hbhkx <kxhuang0@gmail.com>
+# Contributor: Israel Herraiz <isra@herraiz.org>
pkgname=suitesparse-mkl
-pkgver=4.5.5
+pkgver=5.6.0
pkgrel=1
-pkgdesc="A collection of sparse matrix libraries (compiled with the Intel MKL lib)"
+pkgdesc="A collection of sparse matrix libraries (compiled with the Intel MKL and Intel TBB)"
url="http://faculty.cse.tamu.edu/davis/suitesparse.html"
arch=('i686' 'x86_64')
-conflicts=('umfpack', 'suitesparse')
-provides=('umfpack', 'suitesparse=${pkgver}')
-replaces=('umfpack', 'suitesparse')
+gblasver=3.1.1
+conflicts=('umfpack' 'graphblas' 'suitesparse')
+provides=('umfpack' 'graphblas=${gblasver}' 'suitesparse=${pkgver}')
+replaces=('umfpack' 'graphblas' 'suitesparse')
depends=('metis' 'intel-mkl' 'intel-tbb')
-makedepends=('intel-compiler-base' 'intel-fortran-compiler' 'cmake' 'chrpath')
+makedepends=('intel-compiler-base' 'intel-fortran-compiler' 'cmake')
license=('GPL')
-options=('staticlibs')
-source=("http://faculty.cse.tamu.edu/davis/SuiteSparse/SuiteSparse-$pkgver.tar.gz" suitesparse-link-tbb.patch)
-sha1sums=('60b7778e6d5e7304f1f7f337874de8a631b470b0'
- '4f0b3836e8c3c1ec5be01f988f136cee4a2cb936')
+options=()
+source=("https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/v${pkgver}.tar.gz" suitesparse-mkl_tbb.patch)
+sha1sums=('3de08b5ab02610ed0446225aad2445696616fae5'
+ 'f3620f3d447279ff992e4b42f4cc40ce98afe643')
prepare() {
# Fix linking with intel-tbb