summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntony Lee2016-03-30 23:13:46 -0700
committerAntony Lee2016-03-30 23:18:37 -0700
commitadf33ebca07f50031b445d6826b97cb08128310b (patch)
treeffb0906571c5d67786fd70f60712d43ab8f32b36 /PKGBUILD
downloadaur-adf33ebca07f50031b445d6826b97cb08128310b.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9fe61ef95b50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Antony Lee <anntzer dot lee at gmail dot com>
+
+# Please follow the instructions at http://home.planet.nl/~narcis45/suitplay/
+# to obtain suitplay.zip.
+
+pkgname=suitplay
+pkgver=2.1.2
+pkgrel=1
+pkgdesc='A program that determines optimal play of suit combinations in bridge.'
+arch=('any')
+url='http://home.planet.nl/~narcis45/suitplay/'
+license=('custom')
+depends=('wine')
+install="$pkgname.install"
+source=('file://suitplay.zip'
+ 'file://SuitPlayEULA.txt')
+md5sums=('1d42a581b1647f150921fd650dfc4ee6'
+ '3ec142762e4aa49073d571b5529774c5')
+
+package() {
+ mkdir -p "$pkgdir/usr/share/$pkgname"
+ cp "$srcdir/SuitPlay.exe" "$pkgdir/usr/share/$pkgname"
+
+ mkdir "$pkgdir/usr/bin"
+ cat <<EOF >"$pkgdir/usr/bin/suitplay"
+#!/bin/sh
+cd /usr/share/$pkgname
+wine SuitPlay.exe
+EOF
+ chmod a+x "$pkgdir/usr/bin/suitplay"
+
+ install -D -m644 SuitPlayEULA.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ ln -s "/usr/share/licenses/$pkgname/LICENSE" "$pkgdir/usr/share/$pkgname/SuitPlayEULA.txt"
+}