summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAleksandar Trifunovic2024-01-16 15:56:26 +0100
committerAleksandar Trifunovic2024-01-16 15:56:26 +0100
commita5e47725d1b01601f0fd602904ca59f47b137a6a (patch)
tree93ee4523d9d8bd4c1916d9a24484d5f79df6babf /PKGBUILD
parent95fa7aa0ab010a9c36bd551ba43909a485e45a81 (diff)
downloadaur-a5e47725d1b01601f0fd602904ca59f47b137a6a.tar.gz
v1.19.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da3a4de8a9ca..c89795f3a13e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,27 +6,26 @@
SUMO_HOME='/usr/share/sumo'
pkgname=('sumo' 'sumo-doc')
pkgbase=sumo
-pkgver=1.18.0
+pkgver=1.19.0
_pkgver="${pkgver//./_}"
pkgrel=1
pkgdesc="Traffic simulation modelling road vehicles, public transport and pedestrians."
arch=('i686' 'x86_64')
url="http://sumo.dlr.de"
license=('GPL')
-depends=('openscenegraph' 'python' 'proj' 'fox' 'xerces-c' 'gdal' 'gl2ps')
-makedepends=('cmake' 'help2man' 'swig' 'gtest' 'gmock')
+depends=('openscenegraph' 'python' 'proj' 'fox' 'xerces-c' 'gdal' 'gl2ps' 'python-pyproj' 'python-pandas' 'python-scipy')
+makedepends=('cmake' 'help2man' 'swig' 'gtest' 'gmock' 'flake8' 'autopep8' 'python-setuptools')
source=("https://github.com/eclipse/sumo/archive/v${_pkgver}.tar.gz"
"${pkgbase}.desktop")
-sha256sums=('a511ca452180dd9d91f8eb57805db4b3a4e93f653750054981016447c5a46e85'
+sha256sums=('4dc56e66f994b4f1378e357e2c40df55035eac29851252da2f5399b86370f249'
'cc0ed7ad1cce228cd8c634e031c966e1795a16623f0e139ebdcc7ecd06d0bf4d')
prepare() {
cd ${pkgbase}-${_pkgver}
- # remove tests since gtest is min c++14 and sumo builds with c++11
- sed -i '647d' CMakeLists.txt
- sed -i '644d' CMakeLists.txt
+ # workaround for invalid version string generated by sumo
+ sed -i "42i\ return 'v1_19_00'" tools/build/version.py
cmake -H. -Bbuild \
-DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
@@ -43,6 +42,7 @@ build() {
cmake --build build -- man
}
+# example tests still fails
# check() {
# cd ${pkgbase}-${_pkgver}
# cmake --build build -- test