summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormschubert2015-06-12 12:08:13 +0100
committermschubert2015-06-12 12:08:13 +0100
commit0b18eb8d08f888e29417246d98945970e916119b (patch)
tree332ef4a8f4fb9e6e0c76ee13292ff1be8ce98ea4 /PKGBUILD
downloadaur-sundials23.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eefd90fef447
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Michael Schubert <mschu.dev at gmail>
+
+pkgname=sundials23
+_pkgname=sundials
+pkgver=2.3.0
+pkgrel=1
+pkgdesc="Suite of nonlinear differential/algebraic equation solvers"
+arch=('i686' 'x86_64')
+url="https://computation.llnl.gov/casc/sundials/main.html"
+license=('BSD')
+provides=('sundials')
+conflicts=('sundials')
+options=('!libtool')
+source=("http://computation.llnl.gov/casc/sundials/download/code/$_pkgname-$pkgver.tar.gz")
+md5sums=('c236f2a7e0e6a03b8fab3d189471b933')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ ./configure F77=gfortran --prefix=/usr --disable-mpi --with-cflags=-fPIC --enable-shared
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make prefix="$pkgdir/usr" install
+}
+