summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoryjun2021-02-05 20:58:32 +0800
committeryjun2021-02-05 20:58:32 +0800
commit8047a363f7907b32a3ad8557532bf51f7400e384 (patch)
treecf0232a105fbce944ca6e5556c2e94a9b9264f24 /PKGBUILD
parent1efad9142f9ea799e84deec6167e077279240729 (diff)
downloadaur-8047a363f7907b32a3ad8557532bf51f7400e384.tar.gz
removed unnecessary depends and fixed service stops when client logouts
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ba60e9b8676d..f18794fba7f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,11 @@
pkgname=sunloginclient
_pkgname=sunlogin
pkgver=11.0.0.35346
-pkgrel=1
+pkgrel=2
pkgdesc="Proprietary software that supports remote control of mobile devices, Windows, Mac, Linux and other systems.(GUI version)"
arch=("x86_64")
url="https://sunlogin.oray.com"
depends=("libappindicator-gtk3"
- 'aspell'
- 'hspell'
- 'nuspell'
- 'hunspell'
- 'libvoikko'
'xorg-xhost')
license=('custom')
provides=('sunlogin')
@@ -21,8 +16,8 @@ source=("https://down.oray.com/${_pkgname}/linux/${pkgname}-${pkgver}-amd64.deb"
'LICENSE::https://service.oray.com/question/1820.html')
install="${pkgname}.install"
sha256sums=('6f7d6d91f87da0b8dd5f101df5f49e6fa2ab027e01fe34205e920fe48da9c21e'
- 'e23fe5524a0574e3fec38a36b1f87582f75bce68bceaef5982dc3a459eb57e18'
- 'SKIP')
+ '58942243be93d1e743fc42d9670e75a4f33f121faa3d6f2d44c95d73d1ead00c'
+ '92e7d2f15a704ede109a930711d1a70ef8e090f281179a669d8e60c40a736d04')
build() {
mkdir -p build
@@ -34,7 +29,7 @@ package() {
# system service
install -Dm644 ${srcdir}/run${pkgname}.service -t \
- "${pkgdir}/usr/lib/systemd/system/"
+ "${pkgdir}/usr/lib/systemd/system/"
# bin
find usr/local/${_pkgname}/bin -type f -exec \