summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoryjun1232020-07-13 15:33:56 +0800
committeryjun1232020-07-13 15:33:56 +0800
commitfff368000a6510bca78adafb2d2566dded6528d5 (patch)
treed7b283834e5cfcb77dda09d194cf040a4fdb2a1d /PKGBUILD
parentb481c6659968902cb28bfc65d1785e8ef6c0c553 (diff)
downloadaur-fff368000a6510bca78adafb2d2566dded6528d5.tar.gz
update pkgbuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cae750609bd8..1bd78696239b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=sunloginclient
pkgver=10.0.2.24779
-pkgrel=5
+pkgrel=6
pkgdesc="Sunlogin Remote Control is a software that supports remote control of mobile devices, Windows, Mac, Linux and other systems.(GUI version)"
arch=("x86_64")
url="https://sunlogin.oray.com"
@@ -18,7 +18,7 @@ license=('custom')
source=("http://download.oray.com/sunlogin/linux/SunloginClient-${pkgver}_amd64.deb"
'LICENSE::https://service.oray.com/question/1820.html'
'sunlogin-client-xhost.desktop')
-install='sunloginclient.INSTALL'
+install='.INSTALL'
sha256sums=('da2a61d106c2cecce271c89cd182b162bce34018539e1ba431580c5bbe120252'
'SKIP'
'15abf7f89fe7d54112e083914740108a73b6b2cd9d942d49de4c7ccb66c3e30f')
@@ -29,27 +29,31 @@ package() {
install -Dm644 "${pkgdir}/usr/local/sunlogin/scripts/runsunloginclient.service" "${pkgdir}/usr/lib/systemd/system/runsunloginclient.service"
install -dm755 "${pkgdir}/opt"
- cp -rp "${pkgdir}/usr/local/sunlogin" "${pkgdir}/opt/sunlogin"
+ cp -r "${pkgdir}/usr/local/sunlogin" "${pkgdir}/opt/sunlogin"
+ # 删除不必要的文件
rm -r "${pkgdir}/usr/local/"
rm -r "${pkgdir}/opt/sunlogin/scripts"
+
+ # 修改文件权限(需要写入权限执行)
+ chmod 666 "${pkgdir}/opt/sunlogin/res/skin/"*.skin
+ chmod 666 $pkgdir/opt/sunlogin/res/font/wqy-zenhei.ttc
+
# 修改路径
sed -i 's#/usr/local/#/opt/#g' "${pkgdir}/opt/sunlogin/etc/watch.sh"
sed -i "s#/usr/local/#/opt/#g" "${pkgdir}/usr/lib/systemd/system/runsunloginclient.service"
sed -i 's#Exec=/usr/local/sunlogin/#Exec=/usr/#g' "${pkgdir}/usr/share/applications/sunlogin.desktop"
sed -i 's#Icon=/usr/local/sunlogin/res/icon/sunlogin_client.png#Icon=sunlogin_client#g' "${pkgdir}/usr/share/applications/sunlogin.desktop"
- # 修改权限
- chmod 666 "${pkgdir}/opt/sunlogin/res/skin/"*.skin
- chmod 666 $pkgdir/opt/sunlogin/res/font/wqy-zenhei.ttc
-
# 安装图标
install -Dm644 "${pkgdir}/opt/sunlogin/res/icon/sunlogin_client.png" "${pkgdir}/usr/share/pixmaps/sunlogin_client.png"
# 安装协议
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
# 创建软链
install -dm755 "$pkgdir/usr/bin"
+
ln -s "/opt/sunlogin/bin/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ ln -s "/opt/sunlogin/bin/oray_rundaemon" "${pkgdir}/usr/bin/oray_rundaemon"
# xhost +
install -Dm644 "${srcdir}/sunlogin-client-xhost.desktop" "${pkgdir}/etc/xdg/autostart/sunlogin-client-xhost.desktop"