summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorReenigneArcher2022-06-19 02:14:02 +0000
committerReenigneArcher2022-06-19 02:14:02 +0000
commit3e651e904e8a41d2dbaeea966692f3a976c8e61b (patch)
treeccaa7d39aa8e4a8253792bb7221d3094d1025a55 /PKGBUILD
parent1cb1186ae7d4fd63f648874b632249a31f070da2 (diff)
downloadaur-3e651e904e8a41d2dbaeea966692f3a976c8e61b.tar.gz
Automated AUR package update (testing)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 12 insertions, 40 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b603e5541122..7f1c0ea13cc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,27 @@
-# Maintainer: Jacek Szafarkiewicz <szafar at linux dot pl>
-# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Edit on github: https://github.com/SunshineStream/Sunshine/tree/nightly/packaging/linux/aur/PKGBUILD
+# Reference: https://wiki.archlinux.org/title/PKGBUILD
pkgname=sunshine-git
-pkgver=0.13.0.957.4b658cd
+pkgver=0.14.0
pkgrel=1
-pkgdesc="Open source implementation of NVIDIA's GameStream, as used by the NVIDIA Shield"
-url="https://github.com/SunshineStream/sunshine"
+pkgdesc="Sunshine is a Gamestream host for Moonlight."
arch=('x86_64' 'i686')
+url=https://sunshinestream.github.io
license=('GPL3')
-depends=('boost-libs' 'ffmpeg4.4' 'openssl' 'libpulse' 'opus' 'libxtst' 'libx11' 'libxfixes' 'libevdev' 'libxcb' 'libxrandr' 'udev')
+depends=('boost-libs' 'ffmpeg4.4' 'libpulse' 'libevdev' 'libx11' 'libxcb' 'libxfixes' 'libxrandr' 'libxtst' 'openssl' 'opus' 'udev')
makedepends=('git' 'cmake' 'boost' 'make')
provides=('sunshine')
conflicts=("sunshine")
-source=("$pkgname::git+https://github.com/SunshineStream/sunshine.git"
- "systemd-user-config.patch"
- "udev.rules")
-sha256sums=('SKIP'
- '1642eb8672b137e94aa16e4aadde37f68bf1920dfadd1325cca480d7731f38c9'
- '5ce01689247cb01d3f119cac32c731607d99bb875dcdd39c92b547f76d2befa0')
+source=("$pkgname::git+https://github.com/SunshineStream/Sunshine.git#tag=v$pkgver")
+sha256sums=('SKIP')
install=sunshine.install
-_assets_path=/usr/share/sunshine
-
-pkgver() {
- cd "$pkgname"
- printf "%s.%s.%s" "$(git describe --tags $(git rev-list --tags --max-count=1) | sed 's/^v//')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
prepare() {
cd "$pkgname"
git submodule update --recursive --init
-
- patch -p1 < ../systemd-user-config.patch
}
build() {
@@ -46,8 +33,9 @@ build() {
-B build \
-Wno-dev \
-D SUNSHINE_EXECUTABLE_PATH=/usr/bin/sunshine \
- -D SUNSHINE_ASSETS_DIR="$_assets_path" \
- \
+ -D CMAKE_INSTALL_PREFIX="$pkgdir" \
+ -D SUNSHINE_ASSETS_DIR="local/sunshine/assets" \
+ -D SUNSHINE_CONFIG_DIR="local/sunshine/config" \
-D LIBAVCODEC_INCLUDE_DIR=/usr/include/ffmpeg4.4 \
-D LIBAVCODEC_LIBRARIES=/usr/lib/ffmpeg4.4/libavcodec.so \
-D LIBAVDEVICE_INCLUDE_DIR=/usr/include/ffmpeg4.4 \
@@ -57,27 +45,11 @@ build() {
-D LIBAVUTIL_INCLUDE_DIR=/usr/include/ffmpeg4.4 \
-D LIBAVUTIL_LIBRARIES=/usr/lib/ffmpeg4.4/libavutil.so \
-D LIBSWSCALE_INCLUDE_DIR=/usr/include/ffmpeg4.4 \
- -D LIBAVUTIL_LIBRARIES=/usr/lib/ffmpeg4.4/libavutil.so \
- -D LIBSWSCALE_INCLUDE_DIR=/usr/include/ffmpeg4.4 \
-D LIBSWSCALE_LIBRARIES=/usr/lib/ffmpeg4.4/libswscale.so
make -C build
}
package() {
- pushd "$pkgname/assets"
- install -Dvm644 sunshine.conf "$pkgdir/$_assets_path/sunshine.conf"
- install -Dvm644 apps_linux.json "$pkgdir/$_assets_path/apps_linux.json"
-
- find web shaders/opengl -type f -print0 | xargs -0 -I {} install -Dvm644 {} "$pkgdir/$_assets_path/{}"
- popd
-
- pushd build
- install -Dvm755 sunshine "$pkgdir/usr/bin/sunshine"
- install -Dvm644 sunshine.service "$pkgdir/usr/lib/systemd/user/sunshine.service"
- popd
-
- install -Dvm644 udev.rules "$pkgdir/usr/lib/udev/rules.d/85-sunshine.rules"
+ make install
}
-
-# vim: ts=2 sw=2 et: