summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Runge2020-06-03 22:42:33 +0200
committerDavid Runge2020-06-03 22:42:33 +0200
commit307754c7a8acab1c503b5cfb8f1f3420eae5a8b6 (patch)
tree369bb33ef8ee49da75040a3f3e4cce6cd5d2b371 /PKGBUILD
parenta0a603ff1ef1055ef4a971d618f7f02ef9f39ad6 (diff)
downloadaur-307754c7a8acab1c503b5cfb8f1f3420eae5a8b6.tar.gz
Upgrading to > 3.11.0
PKGBUILD: Renaming link dependency to abletonlink and removing devendoring patch for abletonlink (now included). Removing libscsynth.so from provides (building without LIBSCSYNTH=ON due to upstream issues https://github.com/supercollider/supercollider/issues/4992). Applying latest cmake packaging guidelines. Adding all available sodeps in package() and adding the respective packages to makedepends.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1ad6edb4ce74..5ddbd6de5a84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,23 @@
pkgname=supercollider-git
_name="supercollider"
-pkgver=3.10.4.r724.g1b0e7a0092
+pkgver=3.11.0.r371.g504ce0537b
pkgrel=1
pkgdesc="Environment and programming language for real time audio synthesis and algorithmic composition"
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="https://supercollider.github.io/"
license=('GPL3')
depends=('gcc-libs' 'glibc' 'libx11' 'qt5-base' 'qt5-svg' 'qt5-webengine'
-'qt5-websockets' 'systemd-libs')
+'qt5-websockets')
makedepends=('alsa-lib' 'avahi' 'boost' 'cmake' 'emacs' 'fftw' 'git' 'jack'
-'libsndfile' 'link' 'qt5-tools' 'readline' 'yaml-cpp')
+'libsndfile' 'abletonlink' 'qt5-tools' 'readline' 'systemd-libs' 'yaml-cpp')
checkdepends=('xorg-server-xvfb')
optdepends=('emacs: emacs interface'
'gedit: gedit interface'
'sc3-plugins: additional extension plugins for scsynth')
conflicts=('supercollider')
-provides=('libscsynth.so' 'supercollider')
+provides=('supercollider')
source=("git+https://github.com/${_name}/${_name}.git#branch=develop"
- "${pkgname}-devendor-ableton-link.patch"
"git+https://github.com/ableton/link.git"
"git+https://github.com/${_name}/scel.git"
"git+https://github.com/${_name}/scvim.git"
@@ -29,7 +28,6 @@ source=("git+https://github.com/${_name}/${_name}.git#branch=develop"
"git+https://github.com/timblechmann/nova-simd.git"
"git+https://github.com/timblechmann/nova-tt.git")
sha512sums=('SKIP'
- '8aa14c7bf94b69f0ffa5b6f348544c3df72083d9f39cdf509efee3997e2e93cde2a3a8f6d6a149b3fd431843fec630d22c31c0f0332f2a1fff24c79ca4c16a00'
'SKIP'
'SKIP'
'SKIP'
@@ -57,8 +55,6 @@ prepare() {
git config submodule.external_libraries/yaml-cpp.url "${srcdir}/yaml-cpp"
git config submodule.external_libraries/link.url "${srcdir}/link"
git submodule update
- # devendor ableton link
- patch -Np1 -i ../"${pkgname}-devendor-ableton-link.patch"
}
build() {
@@ -90,14 +86,15 @@ build() {
-DSC_IDE=OFF"
;;
*)
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DLIBSCSYNTH=ON \
+ cmake -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_BUILD_TYPE='None' \
-DFORTIFY=ON \
-DSC_VIM=OFF \
+ -DSYSTEM_ABLETON_LINK=ON \
-DSYSTEM_BOOST=ON \
-DSYSTEM_YAMLCPP=ON \
${_cmake_args} \
+ -Wno-dev \
-B build \
-S .
;;
@@ -115,7 +112,7 @@ package() {
depends+=('libasound.so' 'libavahi-common.so' 'libavahi-client.so'
'libboost_filesystem.so' 'libboost_program_options.so' 'libboost_regex.so'
'libboost_thread.so' 'libfftw3f.so' 'libjack.so' 'libreadline.so'
- 'libsndfile.so' 'libyaml-cpp.so')
+ 'libsndfile.so' 'libudev.so' 'libyaml-cpp.so')
cd "${_name}"
make DESTDIR="${pkgdir}/" install -C build
install -vDm 644 {AUTHORS,{CHANGELOG,README,README_LINUX}.md} \