summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Nikiforov2021-03-18 20:35:42 +0300
committerKonstantin Nikiforov2021-03-18 20:35:42 +0300
commitc1c20fc51340b852f006db7fdba8b52fb2632dc5 (patch)
tree1dc74f2a775ada82ec667570f202a8a63a76569f /PKGBUILD
parent22947e84238aa265e6b7f946bd639020536952be (diff)
downloadaur-supercronic-git.tar.gz
Fixed building.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5166d88d4493..7a95616f4545 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
pkgname=supercronic-git
__gitroot=github.com/aptible/supercronic
-pkgver=r83.41d5ac6
+pkgver=r226.afb376d
pkgrel=1
pkgdesc="Supercronic is a crontab-compatible job runner, designed specifically to run in containers."
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h' 'arm')
url="https://github.com/aptible/supercronic"
license=('MIT')
-makedepends=('git' 'go' 'dep')
+makedepends=('git' 'go' 'bash-bats')
provides=('supercronic')
conflicts=('supercronic')
_gourl=$__gitroot
@@ -15,14 +15,13 @@ sha256sums=('SKIP')
build() {
GOPATH="$srcdir" go get -v -d ${_gourl}
- cd "$srcdir/src/${__gitroot}"
- GOPATH="$srcdir" dep ensure -vendor-only
- GOPATH="$srcdir" go build -v
+ cd "$srcdir/$pkgname"
+ make
}
package() {
mkdir -p "$pkgdir/usr/bin"
- install -p -m755 "$srcdir/src/${__gitroot}/supercronic" "$pkgdir/usr/bin/"
+ install -p -m755 "$srcdir/$pkgname/supercronic" "$pkgdir/usr/bin/"
}
pkgver() {